Pypylon No module detected

mark-lyons report abuse

I was wondering whether you could help me with an issue I'm having? I want to be able to import Pypylon and into a python script I'm writing, in order to execute camera commands. I've followed the online instructions of:

i) downloading pylon I've downloaded the Debian version. I've done this on my desktop (running Ubuntu 20.4) and I have also tried to do this on a Raspberry Pi. In both cases when I open the viewer it connects with the camera no problem. ii) downloading the binary wheel. For my desktop I downloaded the x86_manylinux version for Python 3.8 and for the Raspberry Pi I downloaded the ARM 3.8

Separately, I have also tried to compile it using swig

When I run the python script 'Import pypylon' in all cases above I get a 'module not found' error. I have downloaded a number of other applications successfully including OpenCV and have not come across this error before.

I don't have a huge amount of experience with Python so there may be something basic in the installation process that I'm missing. Looking online I have seen that some other users have had this issue too. Any suggestions you might have would be very welcome.


pylonguy report abuse

could you please post the exact sequence of commands, that you use to install and use pypylon on your desktop and your raspi?

a) From what you describe it is not clear, how you installed pypylon ( systemwide with sudo , or possibly user only ) So there might be the problem, that you have multiple interpreters on your system, and you install into the library of one interpreter, and for your test program, you call the other one. b) For both your intel/amd desktop and your RaspberryPi both 32 and 64bit packages exist, and you might have installed the wrong version for your OS/HW

To get some insight if this is the case, output the versions and paths

uname -a pip –version python -c "import sys ; print(sys.platform, sys.path)"

As a quick check print the pypylon version. python -c "import pypylon.pylon as py; print(py.version)"

T1000 report abuse

The system has got python 2.7 and python 3.7. The default python version was 2.7.

so setting up an alias to python3.7 is a possible solution.

alias python='/usr/bin/python3.7'

Add Answer

Need support?

Just drop us an email to ... Show more